V3.2.14

date:2023-12-13 (仅授权版更新)

1、修复代码生成一些bug问题

2、适配postgres数据库,并支持pg的代码生成

3、代码生成支持excel 数据导入功能

从v3.2.13升级到此版本,覆盖文件,后端依赖需更新,前端覆盖文件即可无需更新依赖。

go get -u github.com/gogf/gf/contrib/drivers/pgsql/v2

//安装后执行 
go mot tidy

数据库有字段更新,请进入数据库执行以下脚本更新:


#2023-12-13 gfast-mysql 如果是mysql执行此语句

ALTER TABLE `tools_gen_table` 
ADD COLUMN `excel_imp` bit NOT NULL DEFAULT b'0' COMMENT '是否导入excel' AFTER `use_virtual`;



#2023-12-13 gfast-pg 如果是pg执行此语句

ALTER TABLE "tools_gen_table" 
  ADD COLUMN "excel_imp" bool NOT NULL DEFAULT false;

COMMENT ON COLUMN "tools_gen_table"."excel_imp" IS '是否导入excel';
作者:管理员  创建时间:2023-12-13 17:55
最后编辑:管理员  更新时间:2024-04-12 18:07